Если при установке SSL-сертификата возникнут проблемы в Вашем домене, CyberPanel создаст самозаверяющий сертификат. Однако большинство браузеров не поддерживают этот сертификат, что приведёт к появлению предупреждения на экране. Ниже Вы найдёте инструкции по устранению этой проблемы.

Для всех шагов Вы должны получить доступ к VPS root через SSH. После каждого шага Вам нужно будет перепроверять статус SSL-сертификата, чтобы понять, исправили ли его Ваши последние действия.

  1. Обновите CyberPanel до последней версии. Это можно сделать, выполнив эту команду SSH:

    sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)
  2. Обновите ACME SSL Client до последней версии. Для этого следуйте следующей команде:

    wget -O - https://get.acme.sh | sh
  3. Проверьте наличие дополнительных журналов ошибок:

    cat /home/cyberpanel/error-logs.txt

    Вы можете обнаружить ошибки, исправив которые, исправится и ошибка SSL-сертификата.

  4. Выполнить установку SSL с флагом отладки:

    /root/.acme.sh/acme.sh --issue -d yourdomain.com -d www.yourdomain.com --cert-file /etc/letsencrypt/live/www.rmronsol.com/cert.pem --key-file /etc/letsencrypt/live/yourdomain.com/privkey.pem --fullchain-file /etc/letsencrypt/live/yourdomain.com/fullchain.pem -w /home/yourdomain.com/public_html --server letsencrypt --force --debug

ПРИМЕЧАНИЕ:

Вы нашли ответ?